码迷,mamicode.com
首页 > 其他好文 > 详细

Red and Black 深搜

时间:2015-08-28 21:34:33      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:


B - Red and Black
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题意:就是数一下一个@所在的位置可以走多少步的问题。
思路:找到@的地方进行深搜有四个方向,没有剪枝
AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
char map[20][20];
int b[4]={0,1,-1,0};
int bb[4]={1,0,0,-1};
int r,c;
int sx,sy;
int tol;
int ok(int x,int y){
    if(x<0||y<0||x>=r||y>=c||map[x][y]==‘#‘)return 0;
    return 1;
}
void dfs(int x,int y){
    for(int i=0;i<4;i++){
        map[x][y]=‘#‘;
        if(ok(x+b[i],y+bb[i])){
            tol++;
            dfs(x+b[i],y+bb[i]);
        }
    }
}
int main (){
    while(scanf("%d%d",&c,&r)!=EOF&&r!=0&&c!=0){
        getchar();
        for(int i=0;i<r;++i){
                for(int j=0;j<c;j++){
                   scanf("%c",&map[i][j]);//记住此处gets()是不行的,可能输入空格
                   if(map[i][j]==‘@‘){
                    sx=i;
                    sy=j;
                   }
                }
        if(i<r-1){getchar();}
        }
        tol=1;
        dfs(sx,sy);
        printf("%d\n",tol);
    }
    return 0;
}
这倒以前做过的,看见还是发现有点陌生,长时间不敲就忘了怎么弄,好好强化。。

版权声明:本文为博主原创文章,未经博主允许不得转载。

Red and Black 深搜

标签:

原文地址:http://blog.csdn.net/qiuxueming_csdn/article/details/48057309

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!