码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1058.Humble Numbers【这个题怎么定位呢···就【DP】吧】【8月28】

时间:2015-08-28 21:39:19      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   hdu   dp   

Humble Numbers

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
       假设使用数组f[]进行存储这一序列的所有元素首先使f[1]=1, 表示第一个元素是1, 然后利用4个“指针”, h2=h3=h5=h7=1. 每次我们比较 f[h2]*2, f[h3]*3, f[h5]*5, f[h7]*7 这四个元素的大小把最小的放到序列中并把对应的“指针”+1, 直到生成需要的个数.代码如下:

#include<cstdio>
int minx(int a,int b,int c,int d){//求a,b,c,d最小值
    if(a<b&&a<c&&a<d) return a;
    else if(b<c&&b<d) return b;
    else if(c<d) return c;
    else return d;
}
int main(){
    int f[6000],h2=1,h3=1,h5=1,h7=1,n;
    f[1]=1;
    for(int i=2;i<5843;i++){
        f[i]=minx(2*f[h2],3*f[h3],5*f[h5],7*f[h7]);
        if(f[i]==2*f[h2]) h2++;
        if(f[i]==3*f[h3]) h3++;//千万别用else,不然就会有重复的数字了
        if(f[i]==5*f[h5]) h5++;//注意!
        if(f[i]==7*f[h7]) h7++;//千万注意!
    }
    while(scanf("%d",&n)==1&&n)//下面这行代码我觉得我写的挺有意思的,嘿嘿。不断的连接起来~~自己仔细看看,挺好玩的
        printf("The %d%s humble number is %d.\n",n,n%100==11?"th":n%100==12?"th":n%100==13?"th":n%10==1?"st":n%10==2?"nd":n%10==3?"rd":"th",f[n]);
    return 0;
}
技术分享
因为有注释,所以代码长度比实际的长,813B。

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1058.Humble Numbers【这个题怎么定位呢···就【DP】吧】【8月28】

标签:acm   c++   hdu   dp   

原文地址:http://blog.csdn.net/a995549572/article/details/48056659

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!