码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM Bone Collector (dp 01)

时间:2015-08-28 21:40:02      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   编程   hdu   dp   

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40414    Accepted Submission(s): 16794


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
技术分享

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

Author
Teddy
 

Source
 

Recommend

表示都这个时候了才开始做dp  ,猛整他!
/*=============================================================================
#
#      Author: liangshu - cbam 
#
#      QQ : 756029571 
#
#      School : 哈尔滨理工大学 
#
#      Last modified: 2015-08-28 19:18
#
#     Filename: B.cpp
#
#     Description: 
#        The people who are crazy enough to think they can change the world, are the ones who do ! 
=============================================================================*/
#


#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
struct A
{
    int val, v;
}E[1011];

int main(){
    int T;
    int dp[1011];
    cin>>T;
    int n, v;
    while(T--){
        scanf("%d%d",&n, &v);
        for(int i = 1; i <= n; i++){
            scanf("%d",&E[i].val);
        }
        for(int i = 1; i <= n; i++){
            scanf("%d",&E[i].v);
           } 
        memset(dp, 0, sizeof(dp));
            for(int i = 1; i <= n; i++){
                for(int V = v; V >= E[i].v; V--){
                    dp[V] = max(dp[V], dp[V - E[i].v] + E[i].val);
                }
            
        }
    printf("%d\n",dp[v]);
    }
    return 0; 
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

杭电 HDU ACM Bone Collector (dp 01)

标签:acm   算法   编程   hdu   dp   

原文地址:http://blog.csdn.net/lsgqjh/article/details/48056515

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!