码迷,mamicode.com
首页 > 其他好文 > 详细

USACO 1.1 Milking Cows

时间:2015-08-29 07:26:04      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:

Milking Cows

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

  • The longest time interval at least one cow was milked.
  • The longest time interval (after milking starts) during which no cows were being milked.

PROGRAM NAME: milk2

INPUT FORMAT

Line 1: The single integer
Lines 2..N+1: Two non-negative integers less than 1,000,000, respectively the starting and ending time in seconds after 0500

SAMPLE INPUT (file milk2.in)

3
300 1000
700 1200
1500 2100

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

SAMPLE OUTPUT (file milk2.out)

900 300

题解:应该算是道超级简单的题 晚上失眠到五点半 索性不睡了。迷迷糊糊码下这道题 竟然一遍就过了

/*
ID: cxq_xia1
PROG: milk2
LANG: C++
*/
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn=5005;
int N;
struct node
{
    int begins,ends;
    friend bool operator < (node a,node b)
    {
        return a.begins > b.begins;
    }

};
node farmers[maxn];
int main()
{
    int ansMilk,ansNoMilk;
    node tmp1,MilkTime,NoMilkTime;
    freopen("milk2.in","r",stdin);
    freopen("milk2.out","w",stdout);
    while(cin >> N)
    {
        priority_queue<node> q;
        for(int i=0;i<N;i++)
        {
            cin >> farmers[i].begins >> farmers[i].ends;
            q.push(farmers[i]);
        }
        tmp1=q.top();
        q.pop();
        MilkTime=tmp1;
        ansMilk=MilkTime.ends-MilkTime.begins;
        ansNoMilk=0;
        while(!q.empty())
        {
            tmp1=q.top();
            q.pop();
            if(tmp1.begins>MilkTime.ends)
            {
                NoMilkTime.begins=MilkTime.ends;
                NoMilkTime.ends=tmp1.begins;
                if(ansNoMilk<(tmp1.begins-MilkTime.ends))
                    ansNoMilk=NoMilkTime.ends-NoMilkTime.begins;

                MilkTime=tmp1;
                if(ansMilk<MilkTime.ends-MilkTime.begins)
                        ansMilk=MilkTime.ends-MilkTime.begins;
            }
            else
            {
                if(tmp1.ends>MilkTime.ends)
                {
                    MilkTime.ends=tmp1.ends;
                    if(ansMilk<MilkTime.ends-MilkTime.begins)
                        ansMilk=MilkTime.ends-MilkTime.begins;
                }
            }
        }
        cout <<ansMilk<<" "<<ansNoMilk<<endl;
    }
    return 0;
}

  

USACO 1.1 Milking Cows

标签:

原文地址:http://www.cnblogs.com/WillsCheng/p/4768307.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!