标签:
1588: [HNOI2002]营业额统计
Time Limit: 5 Sec Memory Limit: 162 MB
Submit: 10828 Solved: 3771
[Submit][Status][Discuss]
Description
营业额统计 Tiger最近被公司升任为营业部经理,他上任后接受公司交给的第一项任务便是统计并分析公司成立以来的营业情况。 Tiger拿出了公司的账本,账本上记录了公司成立以来每天的营业额。分析营业情况是一项相当复杂的工作。由于节假日,大减价或者是其他情况的时候,营业额会出现一定的波动,当然一定的波动是能够接受的,但是在某些时候营业额突变得很高或是很低,这就证明公司此时的经营状况出现了问题。经济管理学上定义了一种最小波动值来衡量这种情况:
该天的最小波动值 当最小波动值越大时,就说明营业情况越不稳定。 而分析整个公司的从成立到现在营业情况是否稳定,只需要把每一天的最小波动值加起来就可以了。你的任务就是编写一个程序帮助Tiger来计算这一个值。 第一天的最小波动值为第一天的营业额。 输入输出要求
Input
第一行为正整数 ,表示该公司从成立一直到现在的天数,接下来的n行每行有一个整数(有可能有负数) ,表示第i天公司的营业额。
Output
输出文件仅有一个正整数,即Sigma(每天最小的波动值) 。结果小于2^31 。
Sample Input
6
5
1
2
5
4
6
Sample Output
12
HINT
结果说明:5+|1-5|+|2-1|+|5-5|+|4-5|+|6-5|=5+4+1+0+1+1=12
此题数据有问题,详见讨论版http://www.lydsy.com/JudgeOnline/wttl/wttl.php?pid=1588
Source
应该很多平衡树都可以做,splay第一题,不过感觉splay慢了点,就当练手了
ac代码
/**************************************************************
Problem: 1588
User: kxh1995
Language: C++
Result: Accepted
Time:1128 ms
Memory:2836 kb
****************************************************************/
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define min(a,b) (a>b?b:a)
#define N 100005
#define INF 0x3f3f3f3f
using namespace std;
int pre[N],key[N],ch[N][2],root,tot1;
int n;
void newnode(int &r,int fa,int k)
{
r=++tot1;
pre[r]=fa;
key[r]=k;
ch[r][0]=ch[r][1]=0;
}
void rotate(int x,int kind)
{
int y=pre[x];
ch[y][!kind]=ch[x][kind];
pre[ch[x][kind]]=y;
if(pre[y])
{
ch[pre[y]][ch[pre[y]][1]==y]=x;
}
pre[x]=pre[y];
ch[x][kind]=y;
pre[y]=x;
}
void splay(int r,int goal)
{
while(pre[r]!=goal)
{
if(pre[pre[r]]==goal)
rotate(r,ch[pre[r]][0]==r);
else
{
int y=pre[r];
int kind=ch[pre[y]][0]==y;
if(ch[y][kind]==r)
{
rotate(r,!kind);
rotate(r,kind);
}
else
{
rotate(r,kind);
rotate(r,kind);
}
}
}
if(goal==0)
root=r;
}
int insert(int k)
{
int r=root;
while(ch[r][key[r]<k])
{
if(key[r]==k)
{
splay(r,0);
return 0;
}
r=ch[r][key[r]<k];
}
newnode(ch[r][key[r]<k],r,k);
splay(ch[r][key[r]<k],0);
return 1;
}
int get_pre(int x)
{
int temp=ch[x][0];
if(temp==0)
return INF;
while(ch[temp][1])
temp=ch[temp][1];
// printf("++++++%d %d\n",key[temp],key[x]);
return key[x]-key[temp];
}
int get_next(int x)
{
int temp=ch[x][1];
if(temp==0)
return INF;
while(ch[temp][0])
temp=ch[temp][0];
// printf("******%d %d\n",key[temp],key[x]);
return key[temp]-key[x];
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
root=tot1=0;
int ans=0;
for(int i=1;i<=n;i++)
{
int num;
if(scanf("%d",&num)==EOF)//变态啊,不这么写会wa
num=0;
// scanf("%d",&num);
if(i==1)
{
ans+=num;
newnode(root,0,num);
continue;
}
if(!insert(num))
continue;
int a=get_pre(root);
int b=get_next(root);
ans+=min(a,b);
}
printf("%d\n",ans);
}
}
?
版权声明:本文为博主原创文章,未经博主允许不得转载。
BZOJ 题目1588: [HNOI2002]营业额统计(Splay Tree 求前驱后继)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/48093851