码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5422 Rikka with Graph

时间:2015-08-30 11:19:08      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 182    Accepted Submission(s): 95

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:
Yuta has a non-direct graph with n技术分享
vertices and m技术分享
edges. The length of each edge is 1. Now he wants to add exactly an edge which connects two different vertices and minimize the length of the shortest path between vertice 1 and vertice n技术分享
. Now he wants to know the minimal length of the shortest path and the number of the ways of adding this edge.
It is too difficult for Rikka. Can you help her?
 
Input
There are no more than 100 testcases.
For each testcase, the first line contains two numbers n,m(2n100,0m100)技术分享
.
Then m技术分享
lines follow. Each line contains two numbers u,v(1u,vn)技术分享
, which means there is an edge between u技术分享
and v技术分享
. There may be multiedges and self loops.
 
Output
For each testcase, print a single line contains two numbers: The length of the shortest path between vertice 1 and vertice n技术分享
and the number of the ways of adding this edge.
 
Sample Input
2 1
1 2
Sample Output
1 1
这道题看似是一个图论题, 然而仔细一看就水的不行啦。 如果 1 和点 n 没有直接相连的路径, 那么最短路径就是这一条。 否则,最短路径还是这一条。 但是连线的方案确是任意乱连都可以。有 n*(n-1)/2个连法。
当时对题意理解错啦:  理解为添加一条路径使1到其他点路径的总和最小。 (呜呜呜呜~~~~)
#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
    int m, n;
    while(~scanf("%d%d", &n, &m))
    {
        int u, v;
        int ok = 0;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d", &u, &v);
            if((u==1&&v==n)||(v==1&&u==n))
            ok = 1;
        }
        if(!ok) printf("%d %d\n",1, 1);
        else printf("%d %d\n",1, n*(n-1)/2);
    }
    return 0;
} 

 

HDU 5422 Rikka with Graph

标签:

原文地址:http://www.cnblogs.com/acm1314/p/4770446.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!