Source : hdu 3790 最短路径问题
Problem Description
给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。
Input
输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。
(1< n<=1000, 0< m<100000, s != t)
Output
输出 一行有两个数, 最短距离及其花费。
与最短路不同的是,告诉你每条路的费用,问在最短路长度相同的情况下,输出所花费的最小费用
Sample Input
3 2
1 2 5 6
2 3 4 5
1 3
0 0
Sample Output
9 11
最短路条件下的最小费用(有条件的!),再增加一个变量,修改堆优先级即可,注意初始化和加边条件的改变!
最短路:Dijkstra算法 + 堆优化 O(nlogn)
/*Dijkstra算法 + 堆优化O(ElogE)*/
#include<bits/stdc++.h>
#define clr(k,v) memset(k,v,sizeof(k))
#define INF 0x3f3f3f3f
using namespace std;
const int _max = 1000 + 10;
int n,m,u,v,w,val,st,ed;
struct qnode{
int v,c,val;
qnode(int _v = 0,int _c = 0,int _val= 0):v(_v),c(_c),val(_val){}
bool operator < (const qnode &r)const{//定义优先级
if(c == r.c) return val > r.val;
return c > r.c;
}
};
struct Edge{
int v,cost,val;
Edge(int _v = 0,int _cost = 0,int _val = 0):v(_v),cost(_cost),val(_val){}
};
vector<Edge>E[_max];
bool vis[_max];
int dist[_max],value[_max];//vlaue是在最短路径下的最小费用
//点的编号从1开始
void Dijkstra(int n,int start){
clr(vis,0);
for(int i = 1; i <= n; ++ i) dist[i] = INF;
priority_queue<qnode>pq;
while(!pq.empty()) pq.pop();
dist[start] = 0;
value[start] = 0;//初始化要加上!
pq.push(qnode(start,0,0));
qnode tmp;
while(!pq.empty()){
tmp = pq.top();
pq.pop();
int u = tmp.v;
if(vis[u]) continue;
vis[u] = true;
for(int i = 0; i < E[u].size(); ++ i){
int v = E[tmp.v][i].v;
int cost = E[u][i].cost;
int val = E[u][i].val;
if(!vis[v] && dist[v] >= dist[u] + cost){//注意等于==
dist[v] = dist[u] + cost;
value[v] = value[u] + val;
pq.push(qnode(v,dist[v],value[v]));
}
}
}
}
void addedge(int u,int v,int w,int c){
E[u].push_back(Edge(v,w,c));
E[v].push_back(Edge(u,w,c));//无向图注意push两次!!!
}
int main(){
#ifndef ONLINE_JUDGE
freopen("input.txt","r",stdin);
#endif // ONLINE_JUDGE
while(scanf("%d%d",&n,&m) == 2 && (n || m)){
for(int i = 0; i <= n; ++ i) E[i].clear();//初始化
for(int i = 0; i < m; ++ i){
scanf("%d%d%d%d",&u,&v,&w,&val); //邻接表存储,重边不用考虑的!
addedge(u,v,w,val);//编号从1开始
}
scanf("%d%d",&st,&ed);
Dijkstra(n,st);//起点到终点
printf("%d %d\n",dist[ed],value[ed]);
}
return 0;
}
Ctrl + B
Ctrl + I
Ctrl + Q
Ctrl + L
Ctrl + K
Ctrl + G
Ctrl + H
Ctrl + O
Ctrl + U
Ctrl + R
Ctrl + Z
Ctrl + Y
版权声明:本文为博主原创文章,未经博主允许不得转载。
原文地址:http://blog.csdn.net/u012717411/article/details/48103233