码迷,mamicode.com
首页 > 其他好文 > 详细

SDUT 3315 a

时间:2015-08-30 19:35:58      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:数论

We have a graph with size = N like that in Figure 1. Then we are going to find a downward path from the top node to one bottom node.
  
First, we select the top node as the beginning. Then at any node, we can go horizontally or downward along the blue edge and reach the next node. The finding will be end when we reach one of the bottom nodes. After that we can get a downward path from the top node to one bottom node. Note that we can not pass a blue edge that we have passed ago during each finding.
  
Your task is to calculate there exists how many downward paths.

                                                                                      【图片3315-1】技术分享

输入

For each test case, there is only one integer N (1 <= N <= 10^18) indicates the size of the graph.

输出

For each test case, you should output the correct answer of the above task in one line.Because the answer may be very large, you should just output the remainder of it divided by 1000003.

示例输入

1
2

示例输出

2
8

提示

 For Sample 2, the yellow paths in Figure 2 show the 8 downward paths.

【图片3315-2】技术分享


分析当前的的路径方式是怎么推来的,必定是上层累乘的步数*当前的步数得来的。数据太大数组不可能开的了。

分析得到当前的层的向下通向的路径累乘起来即可。


#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<cmath>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;

int main()
{
    LL n,m,i,j,k,cla;
    while(~scanf("%lld",&n))
    {
        if(n==1)
        {
            printf("2\n");
            continue;
        }
        LL ans=2;
        LL a=1;
        for(i=2;i<=n;i++)
        {
            a=i*2;
            ans=(ans*a)%1000003;
        }
        printf("%lld\n",ans%1000003);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

SDUT 3315 a

标签:数论

原文地址:http://blog.csdn.net/grit_icpc/article/details/48107165

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!