码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3699 Dakar Rally(单调队列)

时间:2015-08-30 23:07:59      阅读:353      评论:0      收藏:0      [点我收藏+]

标签:

Dakar Rally

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Description

The Dakar Rally is an annual Dakar Series rally raid type of off-road race, organized by the Amaury Sport Organization. The off-road endurance race consists of a series of routes. In different routes, the competitors cross dunes, mud, camel grass, rocks, erg and so on.

Because of the various circumstances, the mileages consume of the car and the prices of gas vary from each other. Please help the competitors to minimize their payment on gas.

Assume that the car begins with an empty tank and each gas station has infinite gas. The racers need to finish all the routes in order as the test case descripts.

Input

There are multiple test cases. The first line of input contains an integer T (T ≤ 50) indicating the number of test cases. Then T test cases follow.

The first line of each case contains two integers: n -- amount of routes in the race; capacity -- the capacity of the tank.

The following n lines contain three integers each: mileagei -- the mileage of the ith route; consumei -- the mileage consume of the car in the ith route , which means the number of gas unit the car consumes in 1 mile; pricei -- the price of unit gas in the gas station which locates at the beginning of the ith route.

All integers are positive and no more than 105.

Output

For each test case, print the minimal cost to finish all of the n routes. If it‘s impossible, print "Impossible" (without the quotes).

Sample Input

2
2 30
5 6 9
4 7 10
2 30
5 6 9
4 8 10

Sample Output

550
Impossible




#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define bug printf("hihi\n")

#define eps 1e-8
typedef long long ll;

using namespace std;
#define N 100005

#define INF 0x3f3f3f3f

struct stud{
  ll len,price;
}f[N];

int n;
int all;
ll money;

int que[N],head,tail;
int num[N];
int need;

void out(int pos)
{
    int i,j;
    while(head<tail&&f[que[tail-1]].price>=f[pos].price)
    {
        money-=f[que[tail-1]].price*num[que[tail-1]];
        need+=num[que[tail-1]];
        tail--;
    }
}

inline void in(int pos)
{
    que[tail]=pos;
    num[que[tail++]]=need;
    money+=need*f[pos].price;
}

inline void run(int pos)
{
     ll len=f[pos].len;
     while(len)
     {
         ll temp=len;
         if(temp>num[que[head]]) temp=num[que[head]];
         num[que[head]]-=temp;
         len-=temp;
         if(num[que[head]]==0) head++;
     }
}

void solve()
{
    int i,j;
    head=tail=0;
    money=0;
    memset(num,0,sizeof(num));

    for(i=1;i<=n;i++)
    {
        need= i==1 ? all:f[i-1].len;
        out(i);
        in(i);
        run(i);
    }
    while(head<tail)
    {
        money-=(ll)num[que[head]]*f[que[head]].price;
        head++;
    }
    printf("%lld\n",money);
}

int main()
{
    int i,j,t,ca=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&all);
        int x,y;
        bool flag=false;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&x,&y,&f[i].price);
            f[i].len=(ll)x*y;
            if(f[i].len>all) flag=true;
        }
        if(flag)
        {
            printf("Impossible\n");
            continue;
        }
        solve();
    }
    return 0;
}









版权声明:本文为博主原创文章,未经博主允许不得转载。

zoj 3699 Dakar Rally(单调队列)

标签:

原文地址:http://blog.csdn.net/u014737310/article/details/48111721

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!