码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1985 Cow Marathon

时间:2015-08-31 17:10:21      阅读:283      评论:0      收藏:0      [点我收藏+]

标签:

题目连接

http://poj.org/problem?id=1985   

Cow Marathon

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

树的直径。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using std::map;
using std::min;
using std::find;
using std::pair;
using std::queue;
using std::vector;
using std::multimap;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 50010;
const int INF = 0x3f3f3f3f;
struct work {
    struct edge { int to, w, next; }G[N << 1];
    int tot, head[N], dist[N];
    inline void init() {
        tot = 0, cls(head, -1);
    }
    inline void add_edge(int u, int v, int w) {
        G[tot] = (edge){ v, w, head[u] }; head[u] = tot++;
        G[tot] = (edge){ u, w, head[v] }; head[v] = tot++;
    }
    inline int bfs(int s) {
        int id = s, max_dist = 0;
        cls(dist, -1);
        queue<int> q;
        q.push(s);
        dist[s] = 0;
        while(!q.empty()) {
            int u = q.front(); q.pop();
            if(dist[u] > max_dist) {
                max_dist = dist[id = u];
            }
            for(int i = head[u]; ~i; i = G[i].next) {
                edge &e = G[i];
                if(-1 == dist[e.to]) {
                    dist[e.to] = dist[u] + e.w;
                    q.push(e.to);
                }
            }
        }
        return id;
    }
    inline void solve(int m) {
        char ch;
        int u, v, w;
        cls(head, -1);
        while(m--) {
            scanf("%d %d %d %c", &u, &v, &w, &ch);
            add_edge(u, v, w);
        }
        printf("%d\n", dist[bfs(bfs(u))]);
    }
}go;
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    int n, m;
    while(~scanf("%d %d", &n, &m)) {
        go.solve(m);
    }
    return 0;
}

poj 1985 Cow Marathon

标签:

原文地址:http://www.cnblogs.com/GadyPu/p/4773241.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!