码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2631 Roads in the North

时间:2015-08-31 19:03:47      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

题目连接

http://poj.org/problem?id=2631 

Roads in the North

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

树的直径。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using std::map;
using std::min;
using std::sort;
using std::pair;
using std::queue;
using std::vector;
using std::multimap;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 11000;
const int INF = 0x3f3f3f3f;
struct edge { int to, w, next; }G[N << 1];
int tot, head[N], dist[N];
void init() {
    tot = 0, cls(head, -1);
}
void add_edge(int u, int v, int w) {
    G[tot] = (edge){ v, w, head[u] }; head[u] = tot++;
    G[tot] = (edge){ u, w, head[v] }; head[v] = tot++;
}
int bfs(int u) {
    queue<int> q;
    q.push(u);
    cls(dist, -1);
    int id = 0, maxd = 0;
    dist[u] = 0;
    while(!q.empty()) {
        u = q.front(); q.pop();
        if(dist[u] > maxd) {
            maxd = dist[id = u];
        }
        for(int i = head[u]; ~i; i = G[i].next) {
            edge &e = G[i];
            if(-1 == dist[e.to]) {
                dist[e.to] = dist[u] + e.w;
                q.push(e.to);
            }
        }
    }
    return id;
}
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    init();
    int u, v, w;
    while(~scanf("%d %d %d", &u, &v, &w)) {
        add_edge(u, v, w);
    }
    printf("%d\n", dist[bfs(bfs(1))]);
    return 0;
}

poj 2631 Roads in the North

标签:

原文地址:http://www.cnblogs.com/GadyPu/p/4773395.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!