码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3349 Snowflake Snow Snowflakes

时间:2015-08-31 19:37:49      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:c++   数据结构   poj   hash   

SnowflakeSnowSnowflakes
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 35235   Accepted: 9266

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source


ACcode

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 99809
using namespace std;
int hash[maxn];
struct Sonw{
    int a[6];
    int in(){
        int sum=0;
        for(int i=0;i<6;++i){
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        return sum%=maxn;
    }
};
Sonw m[maxn][2],t;
int cmp(Sonw x, Sonw y){
    int st,i,j;
    for (st =0;st<6;st++){
        for (i=st,j=0;j<6;j++,i=(i+1)%6){
             if(x.a[i] != y.a[j]) break;
        }
         if(j==6) return 1;
     }
     for (st=0;st<6;st++){
        for (i=st,j = 0; j < 6; j++, i = (i + 5) % 6){
            if(x.a[i]!=y.a[j]) break;
        }
         if(j==6) return 1;
     }
     return 0;
}
int main(){
    int n;
    scanf("%d",&n);
    int pos;
    bool flag=true;
    while(n--){
        pos=t.in();
       // cout<<pos<<'\12';
        if(flag){
            for(int j=0;j<hash[pos];++j){
                //cout<<cmp(t,m[pos][j])<<'\12';
                if(cmp(t,m[pos][j])){
                    flag=false;
                    puts("Twin snowflakes found.\n");
                }
            }
            m[pos][hash[pos]]=t;
            hash[pos]++;
        }
    }
    if(flag)puts("No two snowflakes are alike.\n");
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3349 Snowflake Snow Snowflakes

标签:c++   数据结构   poj   hash   

原文地址:http://blog.csdn.net/zp___waj/article/details/48138363

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!