标签:
Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14879 Accepted Submission(s): 9082
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
Sample Output
ac代码:
暴力解法:425ms
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define INF 0x7fffffff
#define MAXN 10010
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int num[MAXN];
int main()
{
int i,j,n;
while(scanf("%d",&n)!=EOF)
{
int M;
int cnt=0;
for(i=0;i<n;i++)
scanf("%d",&num[i]);
for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
if(num[j]<num[i])
cnt++;
}
}
M=cnt;
for(i=0;i<n;i++)
{
cnt=cnt-num[i]+n-1-num[i];
if(M>cnt)
M=cnt;
}
printf("%d\n",M);
}
return 0;
}
看到很多人都用线段树来写,我也想写一下,明天吧!
版权声明:本文为博主原创文章,未经博主允许不得转载。
HDOJ 1394 Minimum Inversion Number 求循环串的最小逆序数(暴力&&线段树)
标签:
原文地址:http://blog.csdn.net/helloiamclh/article/details/48142767