码迷,mamicode.com
首页 > 其他好文 > 详细

1.2 Dual Palindromes

时间:2015-09-03 15:17:18      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:

Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)

and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28


题解: 输入 N 和 S。找出前N个 大于S且转换成其他进制 有两种以上是回文数,输出他。

/*
ID: cxq_xia1
PROG: dualpal
LANG: C++
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int N,S,cntNumPal,cntLen;
char trans[50];
bool isPalsquare(char a[])
{
    for(int i=0;i<cntLen;i++)
    {
        if(i==0&&a[i]==0)
            return false;
        if(trans[i]!=trans[cntLen-1-i])
            return false;
    }
    return true;
}

int main()
{
    freopen("dualpal.in","r",stdin);
    freopen("dualpal.out","w",stdout);

    cin >> N >> S;
    int cnt=1;
    for(int i=1;cnt<=N;i++)
    {
        cntNumPal=0;
        for(int base=2;base<=10;base++)
        {
            int tmp=S+i;
            memset(trans,0,sizeof(trans));
            cntLen=0;
            while(tmp!=0)
            {
                trans[cntLen++]=tmp%base;
                tmp/=base;
            }
            if(isPalsquare(trans))
            {
                cntNumPal++;
            }

            if(cntNumPal>=2)
                break;
        }
        if(cntNumPal>=2)
        {
            cout << S+i <<endl;
            cnt++;
            continue;
        }
    }

    return 0;
}

  

1.2 Dual Palindromes

标签:

原文地址:http://www.cnblogs.com/WillsCheng/p/4780188.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!