码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 1163 Eddy's digital Roots

时间:2014-07-14 20:30:11      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   strong   os   

Eddy‘s digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4275    Accepted Submission(s): 2404


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy‘s easy problem is that : give you the n,want you to find the n^n‘s digital Roots.
 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n‘s digital root on a separate line of the output.
 

Sample Input
2 4 0
 

Sample Output
4 4
 

Author
eddy
九余数定理:

一个数对九取余后的结果称为九余数。

一个数的各位数字之和想加后得到的<10的数字称为这个数的九余数(如果相加结果大于9,则继续各位相加)

<span style="font-size:10px;">#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int n,m;
    while(cin>>n,n)
    {
        m=n;
        for(int i=2;i<=n;i++)
            m=(m*n)%9;
        if(m)
            cout<<m<<endl;
        else
            cout<<"9"<<endl;
    }
    return 0;
}
</span>


杭电 1163 Eddy's digital Roots,布布扣,bubuko.com

杭电 1163 Eddy's digital Roots

标签:des   style   java   color   strong   os   

原文地址:http://blog.csdn.net/fanerxiaoqinnian/article/details/37763295

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!