码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5240

时间:2015-09-05 22:01:21      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 735    Accepted Submission(s): 369

Problem Description

As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i-th course before its exam starts, or he will fail it. The i-th course‘s exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
 

 

Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105, and n lines follow. In each of these lines, there are 3 integers ri,ei,li, where 0ri,ei,li109. 

 

 

Output
For each test case: output ‘‘Case #x: ans‘‘ (without quotes), where x is the number of test cases, and ans is ‘‘YES‘‘ (without quotes) if DRD can pass all the courses, and otherwise ‘‘NO‘‘ (without quotes). 

 

 

Sample Input
2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2 7 1000 2
 

 

Sample Output
Case #1: NO
Case #2: YES
 

 

Source
 
 
 
题目大意:有n次考试,给出第i次考试前需要复习时间r,从现在开始距考试的时间e,以及考试持续时间l,问是否能通过所有考试。
思路:直接模拟。。。。。先按考试开始时间排序,然后直接模拟。
#include<algorithm>
#include<iostream>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
struct node{
    int r, e, l;
}p[1000005];
bool cmp(node a, node b){
    return a.e < b.e;
}
int main()
{
    int t, n, i;
    scanf("%d",&t);
    int cas = 1;
    while(t--)
    {
        scanf("%d",&n);
        for(i = 0; i < n; i++){
            scanf("%d%d%d",&p[i].r,&p[i].e,&p[i].l);
        }
        sort(p, p+n, cmp);
        int sum = 0, flag = 0;
        for(i = 0; i < n; i++)
        {
            sum += p[i].r;
            if(sum > p[i].e){
                flag = 1;
                break;
            }
            sum += p[i].l;
        }
        if(flag)
            printf("Case #%d: NO\n",cas++);
        else
            printf("Case #%d: YES\n",cas++);
    }
    return 0;
}
 
 

HDU5240

标签:

原文地址:http://www.cnblogs.com/acm31415/p/4783924.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!