码迷,mamicode.com
首页 > 其他好文 > 详细

PAT-ADVANCED-1096-Consecutive Factors

时间:2015-09-07 10:45:31      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

 

在n的因子中找出连乘长度最长的(630=3*5*6*7),当存在多条时,使用最小的那条(第一个元素最小)

数据量看得有点吓人2^31

枚举第一个可以被N整除的数(<=sqrt(n)),然后以这个数字为起点进行连乘(粗略计算长度最大为32),复杂度也在可以接受的范围内。

注意N为素数的特殊情况,特判一下即可。

技术分享
#include <bits/stdc++.h>
using namespace std;
int main()
{
    int res = 0, ans = 0;
    int n;
    scanf("%d", &n);
    for(int i = 2; i <= sqrt(n); ++i){
        int tmp = n;
        int start = i;
        int cnt = 0;
        while(tmp % start == 0){
            tmp /= start;
            start++;
            cnt++;
        }
        if(cnt > res){
            res = cnt;
            ans = i;
        }
    }
    if(res == 0){
        printf("%d\n%d", 1, n);
        return 0;
    }
    printf("%d\n", res);
    printf("%d", ans);
    for(int i = 1; i < res; ++i){
        printf("*%d", ans+i);
    }
    return 0;

}
CAPOUIS‘CODE

 

PAT-ADVANCED-1096-Consecutive Factors

标签:

原文地址:http://www.cnblogs.com/capouis/p/4788126.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!