码迷,mamicode.com
首页 > 其他好文 > 详细

PAT-ADVANCED-1097-Deduplication on a Linked List

时间:2015-09-07 12:37:02      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

把一个链表中绝对值重复的元素从原链表删除,并放入新的链表。
技术分享
#include <bits/stdc++.h>
#define MAXN 10000+50
#define MAXV 100000+50
using namespace std;
int absolute(int x);
bool vis[MAXN];
//pair<currentAddress, key>
vector<pair<int,int> > resulting;
vector<pair<int,int> > removed;
//pair<key, nextAddress>
pair<int,int> arr[MAXV];
int main()
{
    memset(vis, false, sizeof(vis));
    int startAddress, num;
    scanf("%d%d", &startAddress, &num);
    for(int i = 0; i < num; ++i){
        int curAddress, val, nextAddress;
        scanf("%d%d%d", &curAddress, &val, &nextAddress);
        arr[curAddress].first = val;
        arr[curAddress].second = nextAddress;
    }
    while(startAddress != -1){
        if(vis[absolute(arr[startAddress].first)]){
            removed.push_back(make_pair(startAddress, arr[startAddress].first));
        }
        else{
            vis[absolute(arr[startAddress].first)] = true;
            resulting.push_back(make_pair(startAddress, arr[startAddress].first));
        }
        startAddress = arr[startAddress].second;
    }
    int sz = resulting.size();
    for(int i = 0; i < sz; ++i){
        if(i != sz-1){
            printf("%05d %d %05d\n", resulting[i].first, resulting[i].second, resulting[i+1].first);
        }
        else{
            printf("%05d %d %d\n", resulting[i].first, resulting[i].second, -1);
        }
    }
    sz = removed.size();
    for(int i = 0; i < sz; ++i){
        if(i != sz-1){
            printf("%05d %d %05d\n", removed[i].first, removed[i].second, removed[i+1].first);
        }
        else{
            printf("%05d %d %d\n", removed[i].first, removed[i].second, -1);
        }
    }
    return 0;

}

int absolute(int x){
    if(x > 0){
        return x;
    }
    else{
        return -x;
    }
}
CAPOUIS‘CODE

 

PAT-ADVANCED-1097-Deduplication on a Linked List

标签:

原文地址:http://www.cnblogs.com/capouis/p/4788285.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!