码迷,mamicode.com
首页 > 其他好文 > 详细

PAT-ADVANCED-1094-The Largest Generation

时间:2015-09-08 12:01:12      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID‘s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

树的层序遍历,统计结点最多的层以及该层上的结点数。
使用队列BFS即可
技术分享
#include <bits/stdc++.h>
#define MAXN 100+50
using namespace std;
int n, m;
vector<int> arr[MAXN];
int res[MAXN];
struct node{
    int id;
    int level;
};
int main(){
    memset(res, 0, sizeof(res));
    scanf("%d%d", &n, &m);
    for(int i = 0; i < m; ++i){
        int par, t, child;
        scanf("%d%d", &par, &t);
        for(int j = 0; j < t; ++j){
            scanf("%d", &child);
            arr[par].push_back(child);
        }
    }
    queue<node> q;
    q.push({1,1});
    while(!q.empty()){
        node top = q.front();
        res[top.level]++;
        q.pop();
        for(int j = 0; j < arr[top.id].size(); ++j){
            q.push({arr[top.id][j], top.level+1});
        }
    }
    int maxNum = 0, k = 0;
    for(int i = 1; i < MAXN; ++i){
        if(res[i] > maxNum){
            maxNum = res[i];
            k = i;
        }
    }
    cout << maxNum << " " << k << endl;
    return 0;
}
CAPOUIS‘CODE

 

PAT-ADVANCED-1094-The Largest Generation

标签:

原文地址:http://www.cnblogs.com/capouis/p/4790919.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!