标签:des style blog java color strong
How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12689 Accepted Submission(s): 6223
Problem Description
Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
Author
Ignatius.L
经典并查集不多做解释 感觉最后一句关于空行的说法比较坑
#include<iostream>
#include<cstdio>
using namespace std;
int gx[1005];
int ans;
int find(int x)
{
while(x!=gx[x])
x=gx[x];
return x;
}
void hb(int x,int y)
{
int i;
int rootx=find(x);
int rooty=find(y);
if(rootx!=rooty)
gx[rooty]=rootx;//for(i=1;i<=n;i++)cout<<gx[i]<<" ";
}
int main()
{
int i,j,t,n,m,a,b;
cin>>t;
while(t--)
{
cin>>n>>m;
for(i=1;i<=n;i++)
gx[i]=i;
for(i=0;i<m;i++)
{
cin>>a>>b;
hb(a,b);
}
ans=0;
for(i=1;i<=n;i++)
{
if(gx[i]==i)
ans++;
}
cout<<ans<<endl;
}
return 0;
}
hdu 1213 How Many Tables,布布扣,bubuko.com
hdu 1213 How Many Tables
标签:des style blog java color strong
原文地址:http://blog.csdn.net/fanerxiaoqinnian/article/details/37805461