码迷,mamicode.com
首页 > 其他好文 > 详细

A - Red and Black(3.2.1)(搜索)

时间:2014-07-15 10:28:09      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   strong   os   

A - Red and Black(3.2.1)
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include<iostream>
#include<cstring>
using namespace std;
int b,c,k,i,s,x,y,n;
char a[21][21]; 
int sousuo(int x,int y,int a1,int b)
{
	int n=0;
	if(x>0)
		if(a[x-1][y]=='.')
		{n++;a[x-1][y]='a';n=n+sousuo(x-1,y,a1,b);}
    if(y>0)
		if(a[x][y-1]=='.')
		{n++;a[x][y-1]='a';n=n+sousuo(x,y-1,a1,b);}
	if(x<a1)
      if(a[x+1][y]=='.')
		{n++;a[x+1][y]='a';n=n+sousuo(x+1,y,a1,b);}
	  if(y<b)
		if(a[x][y+1]=='.')
		{n++;a[x][y+1]='a';n=n+sousuo(x,y+1,a1,b);}
		return n;
}
int main()
{
	int j;
	while(cin>>k>>s&&k)
	{
		memset(a,'q',sizeof(a));
	  for(i=0;i<s;i++)
		  for(j=0;j<k;j++)
		  {
			  cin>>a[i][j];
			  if(a[i][j]=='@')
				  x=i,y=j;
		  }

         n=sousuo(x,y,s,k);
		 cout<<++n<<endl;
	}
	return 0;
}


A - Red and Black(3.2.1)(搜索),布布扣,bubuko.com

A - Red and Black(3.2.1)(搜索)

标签:des   style   http   color   strong   os   

原文地址:http://blog.csdn.net/rememberautumn/article/details/37766973

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!