码迷,mamicode.com
首页 > 其他好文 > 详细

(广搜) Find a way -- hdu -- 2612

时间:2015-09-10 07:08:37      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:

链接:

http://acm.hdu.edu.cn/showproblem.php?pid=2612

 

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6718    Accepted Submission(s): 2236


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

 

Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
 

 

Sample Output
66 88 66

 

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <queue>

using namespace std;

#define INF 0x3f3f3f3f
#define N 210

struct node
{
    int x, y, step;
};

int n, m, a[N][N], dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
char G[N][N];
int vis[N][N];

void BFS(node s, int num)
{
    node p, q;

    queue<node>Q;
    Q.push(s);
    memset(vis, 0, sizeof(vis));
    vis[s.x][s.y] = 1;

    while(Q.size())
    {
        p = Q.front(), Q.pop();

        if(G[p.x][p.y]==@)
        {
            if(num==1)
                a[p.x][p.y] = p.step;
            if(num==2)
                a[p.x][p.y] += p.step;
        }

        for(int i=0; i<4; i++)
        {
            q.x = p.x + dir[i][0];
            q.y = p.y + dir[i][1];
            q.step = p.step + 1;

            if(!vis[q.x][q.y] && q.x>=0 && q.x<n && q.y>=0 && q.y<m && G[q.x][q.y]!=#)
            {

                    vis[q.x][q.y] = 1;
                    Q.push(q);
            }
        }
    }
}

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        int i, j;
        node Y, M;

        memset(a, 0, sizeof(a));

        for(i=0; i<n; i++)
        {
            scanf("%s", G[i]);
            for(j=0; j<m; j++)
            {
                if(G[i][j]==Y)
                    Y.x=i, Y.y=j, Y.step=0;
                if(G[i][j]==M)
                    M.x=i, M.y=j, M.step=0;
            }
        }

        BFS(Y, 1);
        BFS(M, 2);

        int ans=INF;

        for(i=0; i<n; i++)
        for(j=0; j<m; j++)
            if(G[i][j]==@ && vis[i][j])
        ans = min(ans, a[i][j]);

        printf("%d\n", ans*11);

    }
    return 0;
}

 

(广搜) Find a way -- hdu -- 2612

标签:

原文地址:http://www.cnblogs.com/YY56/p/4796657.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!