码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1787 GCD Again【欧拉函数】

时间:2015-09-11 23:25:39      阅读:300      评论:0      收藏:0      [点我收藏+]

标签:

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2673    Accepted Submission(s): 1123


Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem: 
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 

 

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input. 
 

 

Sample Input
2
4
0
 

 

Sample Output
0
1
题意:求2到n-1中与n不互质的数的个数,因为欧拉函数求出的是与n互质的数的个数所以用n-el(n)即可,因为大于一所以还要减去1
#include<stdio.h>
#include<string.h>
int el(int n)
{
	int i;
	int ans=n;
	for(i=2;i*i<=n;i++)//用i*i是为了提高运算效率 
	{                   
		if(n%i==0)
		    ans=ans/i*(i-1);
		while(n%i==0)
		    n/=i;
	}
	if(n>1)//为了避免没有运算到1的情况 
	    ans=ans/n*(n-1);
	return ans;
}
int main()
{
	int n,m,j,i;
	while(scanf("%d",&m),m)
	{
		printf("%d\n",m-el(m)-1);
	}
	return 0;
}

  

 

 

hdoj 1787 GCD Again【欧拉函数】

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4802323.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!