码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5438 Ponds dfs 2015changchun网络赛

时间:2015-09-13 23:03:59      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:

Ponds

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 533    Accepted Submission(s): 175


Problem Description
Betty owns a lot of ponds, some of them are connected with other ponds by pipes, and there will not be more than one pipe between two ponds. Each pond has a value v.

Now Betty wants to remove some ponds because she does not have enough money. But each time when she removes a pond, she can only remove the ponds which are connected with less than two ponds, or the pond will explode.

Note that Betty should keep removing ponds until no more ponds can be removed. After that, please help her calculate the sum of the value for each connected component consisting of a odd number of ponds
 

 

Input
The first line of input will contain a number T(1T30) which is the number of test cases.

For each test case, the first line contains two number separated by a blank. One is the number p(1p104) which represents the number of ponds she owns, and the other is the number m(1m105) which represents the number of pipes.

The next line contains p numbers v1,...,vp, where vi(1vi108) indicating the value of pond i.

Each of the last m lines contain two numbers a and b, which indicates that pond a and pond b are connected by a pipe.
 

 

Output
For each test case, output the sum of the value of all connected components consisting of odd number of ponds after removing all the ponds connected with less than two pipes.
 

 

Sample Input
1
7 7
1 2 3 4 5 6 7
1 4
1 5
4 5
2 3
2 6
3 6
2 7
 

 

Sample Output
21
 

 

Source
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
int p, m;
const int M = 100005;
const int N = 10005;
typedef long long ll;
struct edge
{
    int v, to;
    edge() { };
    edge(int v, int to): v(v), to(to) {};
} e[M];

int head[N], flag[N], val[N], in[N], vis[N], tot;
queue<int> q;

void init()
{
    memset(head, -1, sizeof head);
    memset(flag, 0, sizeof flag);
    memset(vis, 0, sizeof vis);
    memset(in, 0, sizeof in);
    tot = 0;
    while(!q.empty()) q.pop();
}

void addedge(int u, int v)
{
    e[tot] = edge(v, head[u]);
    head[u] = tot++;
}

void dfs(int u)
{
    for(int i = head[u]; i != -1; i = e[i].to)
    {
        int v = e[i].v;
        if(in[v] == 0) continue;
        if(flag[v]) continue;
        in[v]--;
        in[u]--;
        if(in[v] == 1)
        {
            q.push(v);
            flag[v] = 1;
        }
    }
}

void pre()
{
    for(int i = 1; i <= p; ++i)
    {
        if(in[i] == 1)
        {
            flag[i] = 1;
            q.push(i);
        }
    }

    while(!q.empty())
    {
        int f = q.front();
        q.pop();
        dfs(f);
    }
}

int cnt;
ll sum;
void calc(int u)
{
    cnt++;
    vis[u] = 1;
    sum += val[u];
    for(int i = head[u]; i != -1; i = e[i].to)
    {
        int v = e[i].v;
        if(vis[v]) continue;
        if(flag[v]) continue;

        calc(v);

    }
}

int main()
{
    int _;
    scanf("%d", &_);
    while(_ --)
    {
        scanf("%d%d", &p, &m);
        int u, v;
        for(int i = 1; i <= p; ++i) scanf("%d", &val[i]);
        init();
        for(int i = 0; i < m; ++i)
        {
            scanf("%d%d", &u, &v);
            in[u]++;
            in[v]++;
            addedge(u, v);
            addedge(v, u);
        }
        pre();
        ll ans = 0;
        for(int i = 1; i <= p; ++i) if(!flag[i] && !vis[i]) {
                cnt = 0;
                sum = 0;
                calc(i);
                if((cnt & 1) && cnt !=1)  ans += sum;
            }
        printf("%lld\n", ans);
    }
    return 0;
}

  

hdu5438 Ponds dfs 2015changchun网络赛

标签:

原文地址:http://www.cnblogs.com/orchidzjl/p/4805793.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!