码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4405 概率DP

时间:2015-09-15 20:05:50      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

                                         Aeroplane chess

                                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

 

Sample Output
1.1667 2.3441
 

 

Source
 
题解:dp[i]表示出去的期望,逆推就是了
技术分享
//1085422276
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<cmath>
#include<map>
#include<bitset>
#include<set>
#include<vector>
using namespace std ;
typedef long long ll;
#define mem(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,127,sizeof(a));
#define memfy(a) memset(a,-1,sizeof(a))
#define TS printf("111111\n");
#define FOR(i,a,b) for( int i=a;i<=b;i++)
#define FORJ(i,a,b) for(int i=a;i>=b;i--)
#define READ(a,b) scanf("%d%d",&a,&b)
#define mod 1000000007
#define maxn 100000+5
inline ll read()
{
    ll x=0,f=1;
    char ch=getchar();
    while(ch<0||ch>9)
    {
        if(ch==-)f=-1;
        ch=getchar();
    }
    while(ch>=0&&ch<=9)
    {
        x=x*10+ch-0;
        ch=getchar();
    }
    return x*f;
}
//****************************************
int n,m;
double dp[maxn];
int ne[maxn];
int main()
{

    while(READ(n,m)!=EOF)
    {  mem(dp);memfy(ne);
    int x,y;
        if(n==0&&m==0)break;
        FOR(i,1,m)
        {
            scanf("%d%d",&x,&y);
            ne[x]=y;
        }
        FORJ(i,n-1,0)
        {
            if(ne[i]!=-1)dp[i]=dp[ne[i]];
            else {
                FOR(l,1,6)dp[i]+=(dp[i+l]/6.0);
                dp[i]+=1.0;
            }
        }
        printf("%.4f\n",dp[0]);
    }
    return 0;
}
代码

 

HDU 4405 概率DP

标签:

原文地址:http://www.cnblogs.com/zxhl/p/4811055.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!