码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5441

时间:2015-09-15 23:22:51      阅读:278      评论:0      收藏:0      [点我收藏+]

标签:

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1225    Accepted Submission(s): 443


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?
 

 

Input
The first line contains one integer T,T5, which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n20000,m100000,q5000. The Undirected Kingdom has n cities and m bidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b{1,...,n} and d100000. It takes Jack d minutes to travel from city a to city b and vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.

 

 

Output
You should print q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x.

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.
 

 

Sample Input
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

 

Sample Output
2 6 12
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=20010;
const int maxm=100010;
const int maxq=5005;
struct node1{
   int u,v,w;
   node1(){}
   node1(int u,int v,int w):u(u),v(v),w(w) {}
}g[maxm];

struct node2{
   int d,id;
   node2(){}
   node2(int d,int id):d(d),id(id) {}
}que[5005];
long long  ans[5005];
int num[maxn], rak[maxn],father[maxn];
bool cmp1(struct node1 t1,struct node1 t2){
      return t1.w<t2.w;
}
bool cmp2(struct node2 t1,struct node2 t2){
   return t1.d<t2.d;
}


int find(int x){
   if(x!=father[x])
       father[x]=find(father[x]);
    return father[x];
}
long long  tnum;
void Union(int u,int v){
    int x=find(u);
    int y=find(v);
    if(x==y)
        return ;
    tnum+=num[x]*num[y];

    if(rak[x]<rak[y]){
           father[x]=y;
           num[y]+=num[x];
           num[x]=0;
    }
    else {
        father[y]=x;
       if(rak[x]==rak[y])
            ++rak[x];
       num[x]+=num[y];
       num[y]=0;
    }
}

int main(){
   int t;
   scanf("%d",&t);
   while(t--){
      int n,m,q;
    
      scanf("%d%d%d",&n,&m,&q);
      int u,v,w;

    for(int i=1;i<=n;i++){
      father[i]=i;
      num[i]=1;
      rak[i]=0;
    }

      for(int i=0;i<m;i++){
          scanf("%d%d%d",&u,&v,&w);
           g[i]=node1(u,v,w);
      }
      sort(g,g+m,cmp1);
      int d;
      for(int i=0;i<q;i++){
        scanf("%d",&d);
        que[i]=node2(d,i);
      }
      sort(que,que+q,cmp2);
        memset(ans,0,sizeof(ans));
      tnum=0;
      for(int i=0,j=0;i<q;i++){
          int cur=que[i].d;
          while(j<m){
            node1 temp=g[j];
    
             if(cur>=temp.w){
            
                Union(temp.u,temp.v);
             }
             else
                 break;
             j++;
          }
         ans[que[i].id]=tnum;
      }
      for(int i=0;i<q;i++)
          printf("%lld\n",ans[i]*2);

   }
   return 0;
}

 

hdu5441

标签:

原文地址:http://www.cnblogs.com/13224ACMer/p/4811557.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!