码迷,mamicode.com
首页 > 其他好文 > 详细

poj1562 Oil Deposits(深搜dfs)

时间:2014-07-16 10:55:47      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:poj   dfs   

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?id=1562


----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source


代码如下:

#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define TM 117
int n, m, ans, k;
char map[TM][TM];
int vis[TM][TM];
int xx[8] = {1,1,1,0,-1,-1,-1,0};
int yy[8] = {1,0,-1,-1,-1,0,1,1};
void dfs(int x, int y)
{
	vis[x][y] = 1;
	for(int i = 0; i < 8; i++)
	{
		int dx = x+xx[i];
		int dy = y+yy[i];
		if(dx>=0&&dx<n&&dy>=0&&dy<m&&map[dx][dy]=='@'&&!vis[dx][dy])
		{
			vis[dx][dy] = 1;
			dfs(dx,dy);
		}
	}
}
int main()
{
	int i, j;
	while(cin>>n>>m)
	{
		if(n==0 && m==0)
		break;
		memset(vis,0,sizeof(vis));
		k = 0;
		for(i = 0; i < n; i++)
		{
			cin>>map[i];
		}
		for(i = 0; i < n; i++)
		{
			for(j = 0; j < m; j++)
			{
				if(map[i][j] == '@' && !vis[i][j])
				{
					dfs(i,j);
					k++;		
				}
			}
		}
		cout<<k<<endl;
	}
	return 0;
}



poj1562 Oil Deposits(深搜dfs),布布扣,bubuko.com

poj1562 Oil Deposits(深搜dfs)

标签:poj   dfs   

原文地址:http://blog.csdn.net/u012860063/article/details/37822791

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!