标签:des style java color 使用 os
YY‘s new problem
Time Limit: 12000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4061 Accepted Submission(s): 1143
Problem Description
Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i1], P[i2], P[i3] that
P[i1]-P[i2]=P[i2]-P[i3], 1<=i1<i2<i3<=N.
Input
The first line is T(T<=60), representing the total test cases.
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
Output
For each test case, just output ‘Y‘ if such i1, i2, i3 can be found, else ‘N‘.
Sample Input
Sample Output
哈希表基础题:
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define M 10003
int hash[M];
int main ()
{
int t,n,m,i,j;
int flag;
scanf("%d",&t);
while(t--)
{
flag=0;
memset(hash,0,sizeof(hash));
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&m);
hash[m]=1;
if(flag==0)
{
for(j=1;j<m&&j<=n-m;j++) // 写成 m-j>0 && m+j<=n 就易懂了。这样才能保证下面使用hash数组时不越界。
{
if(hash[m-j]+hash[m+j]==1) // 两者只出现过一个
{
flag=1;
break;
}
}
}
}
if(flag) printf("Y\n");
else printf("N\n");
}
return 0;
}
hdu 3833 YY's new problem,布布扣,bubuko.com
hdu 3833 YY's new problem
标签:des style java color 使用 os
原文地址:http://blog.csdn.net/fyxz1314/article/details/37818105