码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1338Game Prediction

时间:2014-07-16 17:18:35      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:acm   杭电   iostream   

Game Prediction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 717    Accepted Submission(s): 385


Problem Description
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
 

Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros.
 

Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
 

Sample Input
2 5 1 7 2 10 9 6 11 62 63 54 66 65 61 57 56 50 53 48 0 0
 

Sample Output
Case 1: 2 Case 2: 4
 

Source
 
通过已给出的数组 a  找出其余所有人的卡牌存放在一个数组 b 中
通过求 b 能赢得最多场max来间接求出 a 能赢得最少场ans
ans=n-max
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int a[55],b[1005];
    int i,j,ans,k,l;
    int n,m,t=0;
    while(cin>>n>>m,m&&n)
    {
        t++;
        memset(b,0,sizeof(b));
        for(i=0;i<m;i++)
            cin>>a[i];
        sort(a,a+m,cmp);
        /*for(i=0;i<m;i++)
        cout<<a[i];*/
        l=0;
        ans=0;
        for(i=m*n;i>a[m-1];i--)
        {   k=0;
            for(j=0;j<m;j++)
             {
                if(a[j]==i)
                   {
                        k=1;
                    continue;
                   }
             }
             if(!k)
             {b[l]=i;/*cout<<b[l]<<" ";*/l++;}
        }
        k=m*(n-1);
        j=0;
        for(i=0;i<m;i++)
           {
              if(a[i]<b[j])
              {
                  ans++;
                  j++;
              }
           }
           cout<<"Case "<<t<<": ";
        cout<<(m-ans)<<endl;
    }

    return 0;
}


hdu 1338Game Prediction,布布扣,bubuko.com

hdu 1338Game Prediction

标签:acm   杭电   iostream   

原文地址:http://blog.csdn.net/fanerxiaoqinnian/article/details/37817205

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!