码迷,mamicode.com
首页 > 其他好文 > 详细

FZU - 2039 Pets (二分图匹配 2011年全国大学生程序设计邀请赛(福州))

时间:2014-07-16 09:17:29      阅读:325      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   os   2014   

Description

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.

bubuko.com,布布扣

Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

Sample Input

1
2 2 2
1 2
2 1

Sample Output

Case 1: 2

Source

2011年全国大学生程序设计邀请赛(福州)
题意:有n个人分别对应不喜欢某个宠物,问最多能卖出去几只
思路:简单的二分图匹配,匈牙利算法模板
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAXN = 110;

int g[MAXN][MAXN], vis[MAXN];
int lined[MAXN];
int n, m, e;

int dfs(int u) {
	for (int v = 1; v <= m; v++) {
		if (g[u][v] && !vis[v]) {
			vis[v] = 1;
			if (lined[v] == -1 || dfs(lined[v])) {
				lined[v] = u;
				return 1;
			}
		}
	}
	return 0;
}

int main() {
	int t, cas = 1;;
	scanf("%d", &t);
	while (t--) {
		memset(g, 1, sizeof(g));
		memset(lined, -1, sizeof(lined));
		scanf("%d%d%d", &n, &m, &e);
		for (int i = 0; i < e; i++) {
			int a, b;
			scanf("%d%d", &a, &b);
			g[a][b] = 0;
		}
		int ans = 0;
		for (int i = 1; i <= n; i++) {
			memset(vis, 0, sizeof(vis));
			if (dfs(i))
				ans++;
		}
		printf("Case %d: ", cas++);
		printf("%d\n", ans);
	}
	return 0;
}




FZU - 2039 Pets (二分图匹配 2011年全国大学生程序设计邀请赛(福州)),布布扣,bubuko.com

FZU - 2039 Pets (二分图匹配 2011年全国大学生程序设计邀请赛(福州))

标签:des   style   blog   http   os   2014   

原文地址:http://blog.csdn.net/u011345136/article/details/37812297

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!