码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3041 Asteroids

时间:2014-07-16 08:22:15      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   2014   

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

题意:题意:矩阵上有一些小行星,占据了一些格子,我们每次操作可以清理一列中的所有小行星,也可以清理一行中的所有小行星,问最少进行多少次操作可以清理掉所有的小行星。

思路:所以本题就是一个最大匹配问题!

AC代码:

#include<stdio.h>
#include<string.h>
int link[520][520];
int vis[520],col[520];
int  w,m;
int match(int x)
{
    int i;
    for(i=1;i<=w;i++){
        if(link[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(!col[i]||match(col[i]))
            {
                col[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{

        int a,b,sum=0;
        memset(link,0,sizeof(link));
        memset(col,0,sizeof(col));
        scanf("%d %d",&w,&m);
        for(int i=1;i<=m;i++){
            scanf("%d %d",&a,&b);
            link[a][b]=1;
        }
        for(int i=1;i<=w;i++){
            memset(vis,0,sizeof(vis));
            if(match(i))sum++;
        }
        printf("%d\n",sum);
        return 0;
}


POJ 3041 Asteroids,布布扣,bubuko.com

POJ 3041 Asteroids

标签:des   style   blog   color   os   2014   

原文地址:http://blog.csdn.net/u012313382/article/details/37668685

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!