码迷,mamicode.com
首页 > 其他好文 > 详细

General Problem Solving Techniques [Beginner-1]~F

时间:2015-09-18 21:42:26      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:

       You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

       Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output

Yes

No

Yes

No

解题思路:题目的大概意思是给出每次两个字符,判断第一个字符串中的字母是否在第二个字符串中出现,需要注意的是,字符可以是不连续的但是顺序不能打乱。用一个循环依次判断至末尾就可以了。

程序代码:

#include<stdio.h>
#include<string.h>
const int N=100010;
char a[N],b[N];
int main()
{
int i,j;
while(scanf("%s%s",&a,&b)!=EOF)
{
for(i=0,j=0;a[i]!=‘\0‘&&b[j]!=‘\0‘;j++)
if(a[i]==b[j]) i++;
if(a[i]==‘\0‘) printf("Yes\n");
else printf("No\n");
}
return 0;
}

General Problem Solving Techniques [Beginner-1]~F

标签:

原文地址:http://www.cnblogs.com/chenchunhui/p/4820280.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!