码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1532(最大流)

时间:2015-09-19 00:59:59      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12771    Accepted Submission(s): 6097


Problem Description
Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

 

Sample Input
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

 

Sample Output
50
 

 

Source
 

 技术分享

题意:给出n个河流,m个点,以及每个河流的流量,求从1到m点的最大流量。

     没啥好说的,裸的最大流,试了一下模板,注意模板的下标。。。

技术分享
#include <cstdio>
#include <iostream>
#include <sstream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define ll long long
#define _cle(m, a) memset(m, a, sizeof(m))
#define repu(i, a, b) for(int i = a; i < b; i++)
#define repd(i, a, b) for(int i = b; i >= a; i--)
#define sfi(n) scanf("%d", &n)
#define pfi(n) printf("%d\n", n)
#define sfi2(n, m) scanf("%d%d", &n, &m)
#define pfi2(n, m) printf("%d %d\n", n, m)
#define pfi3(a, b, c) printf("%d %d %d\n", a, b, c)
#define MAXN 105
#define V 55
//const int INF = 0x3f3f3f3f;

#define maxn 210
const int inf = 0x3f3f3f3f;

struct EK
{
    int cap[maxn][maxn];
    int flow[maxn][maxn];
    int n;
    void init(int n)
    {
        this->n = n;
        memset(cap, 0, sizeof(cap));
    }
    void addCap(int i, int j, int val)
    {
        cap[i][j] += val;
    }
    int solve(int source, int sink)
    {
        if(source == sink)    return inf;///源=汇, 流量无穷大!
        static int que[maxn], pre[maxn], d[maxn];
///bfs时的队列; bfs时某点的前驱; 增光路径的流量
        int p, q, t;///bfs时的队列底、顶; bfs时当前元素
        memset(flow, 0, sizeof(flow));
        while(true)
        {
            memset(pre, 255, sizeof(pre));
            d[source] = inf;
            p = q = 0;
            que[q++] = source;

            while(p<q && pre[sink]==-1)
            {
                t = que[p ++];
                for(int i = 1; i <= n; i ++)
                {
                    if(pre[i]==-1 && cap[t][i]-flow[t][i]>0)
                    {
///残余=cap-flow
                        pre[i] = t;
                        que[q++]=i;
                        d[i] = min(d[t], cap[t][i]-flow[t][i]);
                    }
                }
                 //pfi(1000);
            }
            if(pre[sink]==-1)    break;///没有增广路径了!
            for(int i = sink; i != source; i = pre[i])
            {
                flow[pre[i]][i] += d[sink];
                flow[i][pre[i]] -= d[sink];
            }
        }
        t = 0;///当做网络流量
        for(int i = 1; i <= n; i ++)
        {
            t += flow[source][i];
            //pfi(flow[source][i]);
        }
        return t;
    }
}ek;

int main()
{
    int n, m;
    while(~sfi2(m, ek.n))
    {
        ek.init(ek.n);
        int x, y, z;
        repu(i, 0, m)
        {
            sfi2(x, y), sfi(z);
            ek.addCap(x, y, z);
        }
        pfi(ek.solve(1, ek.n));
    }
    return 0;
}
View Code

 

hdu 1532(最大流)

标签:

原文地址:http://www.cnblogs.com/sunus/p/4820753.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!