码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 2406--Power Strings(KMP)

时间:2015-09-20 14:25:40      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 38544   Accepted: 16001

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

 
KMP, 不好做啊,稳重一点吧, 感觉自己老是多想, 这是成长吗?
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
char str[1000010]; int len, NeXt[1000010];
void GetP()
{
    int i = 0, j = -1;
    NeXt[i] = j;
    while(i < len)
    {
        if(j == -1 || str[i] == str[j])
        {
            i++; j++;
            if(str[i] != str[j])
                NeXt[i] = j;
            else
                NeXt[i] = NeXt[j];
        }
        else
            j = NeXt[j];
    }
        
} 
int main()
{
    while(gets(str), str[0] != .)
    {
        
        len = strlen(str);
        GetP();
        if(len%(len-NeXt[len])==0)
            printf("%d\n", len/(len-NeXt[len]));
        else
            printf("1\n");
    }
    return 0;    
} 

 

 

Poj 2406--Power Strings(KMP)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/4823239.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!