标签:des style blog color strong os
The Suspects
Time Limit: 1000MS |
|
Memory Limit: 20000K |
Total Submissions: 21544 |
|
Accepted: 10433 |
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题意:
有一个学校,有N个学生,编号为0—N-1,现在0号学生感染了非典,凡是和0在一个社团的人就会感染,并且这些人如果还参加了别的社团,他所在的社团照样全部感染,求感染的人数。
思路:对每一组数据找出他们的根节点,然后对‘存在0的一组数据的根节点’比较,如果相同则累加。
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define M 60000
int f[M];
void Makeset(int n)
{
for(int i=0;i<n;i++)
f[i]=i;
}
int findset(int x)
{
if(x!=f[x])
f[x]=findset(f[x]);
return f[x];
}
void Unionset(int x,int y)
{
int fx=findset(x);
int fy=findset(y);
if(fx!=fy)
f[fy]=fx;
}
int main ()
{
int n,m,a,b,t;
int i,j;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0) break;
Makeset(n);
int sum=0;
for(i=0;i<m;i++)
{
scanf("%d",&t);
scanf("%d",&a);
for(j=1;j<t;j++)
{
scanf("%d",&b);
Unionset(a,b);
}
}
for(i=0;i<n;i++)
{
if(findset(0)==findset(i))
sum++;
}
printf("%d\n",sum);
}
return 0;
}
poj 1611 The Suspects,布布扣,bubuko.com
poj 1611 The Suspects
标签:des style blog color strong os
原文地址:http://blog.csdn.net/fyxz1314/article/details/37873425