码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5463Clarke and minecraft

时间:2015-09-20 14:47:34      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:

Clarke and minecraft

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 260    Accepted Submission(s): 136


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a game player of minecraft. 
On that day, Clarke set up local network and chose create mode for sharing his achievements with others. Unfortunately, a naughty kid came his game. He placed a few creepers in Clarke‘s castle! When Clarke returned his castle without create mode, creepers suddenly blew(what a amazing scene!). Then Clarke‘s castle in ruins, the materials scattered over the ground. 
Clark had no choice but to pick up these ruins, ready to rebuild. After Clarke built some chests(boxes), He had to pick up the material and stored them in the chests. Clarke clearly remembered the type and number of each item(each item was made of only one type material) . Now Clarke want to know how many times he have to transport at least. 
Note: Materials which has same type can be stacked, a grid can store 64 materials of same type at most. Different types of materials can be transported together. Clarke‘s bag has 4*9=36 grids.
 

Input
The first line contains a number T(1T10), the number of test cases. 
For each test case: 
The first line contains a number n, the number of items. 
Then n lines follow, each line contains two integer a,b(1a,b500)a denotes the type of material of this item, b denotes the number of this material.
 

Output
For each testcase, print a number, the number of times that Clarke need to transport at least.
 

Sample Input
2 3 2 33 3 33 2 33 10 5 467 6 378 7 309 8 499 5 320 3 480 2 444 8 391 5 333 100 499
 

Sample Output
1 2

水题,有一个背包有36个格子  每个格子只能放一种物品,且最多只能叠加64个  问要多少次才能将物品运完


#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int a[505];

void add()
{
    int sum=0,t=0;
    for(int i=1;i<=500;i++)
    {
        if(a[i])
        {
            sum+=a[i]/64;
            if(a[i]%64) sum++;
            while(sum>=36)
                t++,sum-=36;
        }
    }
    if(sum) t++;
    cout<<t<<endl;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            int s,t;
            cin>>s>>t;
            a[s]+=t;
        }
        add();
    }
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5463Clarke and minecraft

标签:

原文地址:http://blog.csdn.net/u013097262/article/details/48596487

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!