码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5464Clarke and problem(DP)

时间:2015-09-20 14:47:24      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:

Clarke and problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 289    Accepted Submission(s): 131


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a student and read a book.
Suddenly, a difficult problem appears: 
You are given a sequence of number a1,a2,...,an and a number p. Count the number of the way to choose some of number(choose none of them is also a solution) from the sequence that sum of the numbers is a multiple of p(0 is also count as a multiple of p). Since the answer is very large, you only need to output the answer modulo 109+7
 

Input
The first line contains one integer T(1T10) - the number of test cases. 
T test cases follow. 
The first line contains two positive integers n,p(1n,p1000) 
The second line contains n integers a1,a2,...an(|ai|109).
 

Output
For each testcase print a integer, the answer.
 

Sample Input
1 2 3 1 2
 

Sample Output
2 Hint: 2 choice: choose none and choose all.

简单DP题  求n个数中 m个数的和是p的倍数  m~(0-n)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int dp[1010][1010];
int num[1010];
const int Mod=1e9+7;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,p;
        scanf("%d%d",&n,&p);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        int sum=1;
        for(int i=1;i<=n;i++)
        {
            num[i]%=p;
            if(num[i]<0) num[i]+=p;
            for(int j=0;j<p;j++) dp[i][j]=dp[i-1][j];
            dp[i][num[i]]=(dp[i][num[i]]+1)%Mod;
            for(int j=0;j<p;j++)
            {
                dp[i][(num[i]+j)%p]=(dp[i-1][j]+dp[i][(num[i]+j)%p])%Mod;
            }
        }
        printf("%d\n",dp[n][0]+1);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5464Clarke and problem(DP)

标签:

原文地址:http://blog.csdn.net/u013097262/article/details/48596669

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!