码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5461Largest Point

时间:2015-09-20 16:20:10      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:

Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 527    Accepted Submission(s): 228


Problem Description
Given the sequence A with n integers t1,t2,?,tn. Given the integral coefficients a and b. The fact that select two elements ti and tj of A and ij to maximize the value of at2i+btj, becomes the largest point.
 

Input
An positive integer T, indicating there are T test cases.
For each test case, the first line contains three integers corresponding to n (2n5×106), a (0|a|106) and b (0|b|106). The second line contains n integers t1,t2,?,tn where 0|ti|106 for 1in.

The sum of n for all cases would not be larger than 5×106.
 

Output
The output contains exactly T lines.
For each test case, you should output the maximum value of at2i+btj.
 

Sample Input
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
Case #1: 20 Case #2: 0


简单题  求a*ti*ti+b*tj(i!=j)的最大值


#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int tz[5000050],tf[5000050];
bool compare(int a,int b)
{
    return a<b;
}
int main()
{
    int T,tt=1;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        long long a,b;
        int tzlen=0,tflen=0;
        scanf("%d%lld%lld",&n,&a,&b);
        for(int i=0; i<n; i++)
        {
            int num;
            scanf("%d",&num);
            if(num>=0)
                tz[tzlen++]=num;
            else tf[tflen++]=-num;
        }
        sort(tz,tz+tzlen,compare);
        sort(tf,tf+tflen,compare);
        long long Max;
        if(a>=0&&b>=0)
        {
            Max=a*tz[tzlen-1]*tz[tzlen-1]+b*tz[tzlen-2];
            Max=max(Max,a*tz[tzlen-2]*tz[tzlen-2]+b*tz[tzlen-1]);
            Max=max(Max,a*tf[tflen-1]*tf[tflen-1]+b*tz[tzlen-1]);
        }else if(a>=0&&b<0)
        {
            Max=-b*tf[tflen-1]+a*tz[tzlen-1]*tz[tzlen-1];
            Max=max(Max,-b*tf[tflen-1]+a*tf[tflen-2]*tf[tflen-2]);
            Max=max(Max,-b*tf[tflen-2]+a*tf[tflen-1]*tf[tflen-1]);
        }else if(a<0&&b>=0)
        {
            Max=a*tz[0]*tz[0]+b*tz[tzlen-1];
            Max=max(Max,a*tf[0]*tf[0]+b*tz[tzlen-1]);
        }else
        {
            Max=-b*tf[tflen-1]+a*tz[0]*tz[0];
            Max=max(Max,-b*tf[tflen-1]+a*tf[0]*tf[0]);
        }

        printf("Case #%d: %lld\n",tt++,Max);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5461Largest Point

标签:

原文地址:http://blog.csdn.net/u013097262/article/details/48596887

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!