码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1195 Mobile phones

时间:2014-07-16 13:28:32      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:poj   acm   

Mobile phones
Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 14329Accepted: 6660
Description


Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 


Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 
Input


The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

bubuko.com,布布扣


The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 


Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 
Output


Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input


0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3
Sample Output


3

4


一个二维树状数组!

练练模板!!!!!

AC代码如下 :

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define M 100010
#define ll long long
#include<algorithm>
using namespace std;

int cc[1100][1100];
int n;

int lowbit(int a)
{
    return a&-a;
}

void add(int x,int y,int a)
{

    while(x<=1100)
    {
        int y1=y;
        while(y1<=1100)
        {
            cc[x][y1]+=a;
            y1+=lowbit(y1);
        }
        x+=lowbit(x);
    }
}

ll sum(int x,int y)
{
    int ans=0;
    while(x>0)
    {
        int y1=y;
        while(y1>0)
        {
            ans+=cc[x][y1];
            y1-=lowbit(y1);
        }
        x-=lowbit(x);
    }
    return ans;
}


int main()
{
    int i,j;
    int m;
    int a,b,c,d;
    memset(cc,0,sizeof (cc));
    while(1)
    {
        scanf("%d",&m);
        if(m==3)
            break;
        else if(m==0)
            scanf("%d",&n);
        else if(m==1)
        {
            scanf("%d%d%d",&a,&b,&c);
            add(a+1,b+1,c);
        }
        else if(m==2)
        {
            scanf("%d%d%d%d",&a,&b,&c,&d);
            printf("%d\n",sum(c+1,d+1)-sum(a,d+1)-sum(c+1,b)+sum(a,b));
        }
    }
    return 0;
}




POJ 1195 Mobile phones,布布扣,bubuko.com

POJ 1195 Mobile phones

标签:poj   acm   

原文地址:http://blog.csdn.net/hanhai768/article/details/37870443

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!