码迷,mamicode.com
首页 > 其他好文 > 详细

dp_Pku1887

时间:2014-07-16 16:15:03      阅读:278      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   2014   art   

<span style="color:#000099;">/*
A - 简单dp 例题
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit

Status
Description
A military contractor for the Department of Defense has just completed a series of preliminary tests for a new defensive missile called the CATCHER which is capable of intercepting multiple incoming offensive missiles. The CATCHER is supposed to be a remarkable defensive missile. It can move forward, laterally, and downward at very fast speeds, and it can intercept an offensive missile without being damaged. But it does have one major flaw. Although it can be fired to reach any initial elevation, it has no power to move higher than the last missile that it has intercepted.

The tests which the contractor completed were computer simulations of battlefield and hostile attack conditions. Since they were only preliminary, the simulations tested only the CATCHER's vertical movement capability. In each simulation, the CATCHER was fired at a sequence of offensive missiles which were incoming at fixed time intervals. The only information available to the CATCHER for each incoming missile was its height at the point it could be intercepted and where it appeared in the sequence of missiles. Each incoming missile for a test run is represented in the sequence only once.

The result of each test is reported as the sequence of incoming missiles and the total number of those missiles that are intercepted by the CATCHER in that test.

The General Accounting Office wants to be sure that the simulation test results submitted by the military contractor are attainable, given the constraints of the CATCHER. You must write a program that takes input data representing the pattern of incoming missiles for several different tests and outputs the maximum numbers of missiles that the CATCHER can intercept for those tests. For any incoming missile in a test, the CATCHER is able to intercept it if and only if it satisfies one of these two conditions:

The incoming missile is the first missile to be intercepted in this test.
-or-
The missile was fired after the last missile that was intercepted and it is not higher than the last missile which was intercepted.
Input
The input data for any test consists of a sequence of one or more non-negative integers, all of which are less than or equal to 32,767, representing the heights of the incoming missiles (the test pattern). The last number in each sequence is -1, which signifies the end of data for that particular test and is not considered to represent a missile height. The end of data for the entire input is the number -1 as the first value in a test; it is not considered to be a separate test.
Output
Output for each test consists of a test number (Test #1, Test #2, etc.) and the maximum number of incoming missiles that the CATCHER could possibly intercept for the test. That maximum number appears after an identifying message. There must be at least one blank line between output for successive data sets.

Note: The number of missiles for any given test is not limited. If your solution is based on an inefficient algorithm, it may not execute in the allotted time.
Sample Input
389
207
155
300
299
170
158
65
-1
23
34
21
-1
-1
Sample Output
Test #1:
  maximum possible interceptions: 6

Test #2:
  maximum possible interceptions: 2
By Grant Yuan
2014.7.16
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int a[100005];
int f[100005];
int n;
int ct=1;
int main()
{ int t;
    while(t!=-1){
      cin>>a[0];
      if(a[0]==-1)
         break;
      memset(f,0,sizeof(f));
      for(int i=1;;i++){
        scanf("%d",&a[i]);
        n=i;
        f[i]=1;
        if(a[i]==-1)
          break;}
      f[0]=1;
      for(int i=0;i<n;i++){
        for(int j=0;j<i;j++)
          {
             if(a[j]>=a[i])
               {
                   if(f[j]>=f[i])
                   f[i]=f[j]+1;
               }
          }}
      int max=0;
      for(int i=0;i<n;i++)
         if(f[i]>max) max=f[i];
         printf("Test #%d:\n",ct++);
         printf("  maximum possible interceptions: %d\n",max);
         cout<<endl;}
    return 0;
}
</span>

dp_Pku1887,布布扣,bubuko.com

dp_Pku1887

标签:des   style   color   os   2014   art   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/37878499

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!