码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5455 Fang Fang

时间:2015-09-22 18:03:29      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:

Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 709    Accepted Submission(s): 294


Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence F of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F, or nothing could be done but put her away in cold wilderness.
 

 

Input
An positive integer T, indicating there are T test cases.
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106.
 

 

Output
The output contains exactly T lines.
For each test case, if one can not spell the serenade by using the strings in F, output 1. Otherwise, output the minimum number of strings in F to split S according to aforementioned rules. Repetitive strings should be counted repeatedly.
 

 

Sample Input
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 

 

Sample Output
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5467 5466 5465 5464 5463
 
 
把各种特殊的情况找到,不特殊的就是数c的个数。题目可能会出现非c非f的情况,也输出-1
一开始老是wa的原因是越界 str[i+1],str[i+2]超出string长度。 以后可以的话用str.at(i+1),str.at(i+2)保险一点,这个会检查是否越界等
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 1234567

int n,a[N],flag,ans,cnt;

int main()
{

    int T;cin>>T;
    for(int tt = 1; tt <= T; tt++)
    {
        cnt = flag = 0;
        string str = "";
        cin>>str;
        if(str.size() == 1)
        {
            flag = 1;
        }
        else if(str.size() == 2)
        {
            if(str == "ff")
                flag = 0;
            else
                flag = 1;
        }
        else if(str[str.size()-1] == c)
        {
            if(str[0] == c || str[1] == c)
                flag = 1;
        }
        else if(str[0] == c)
        {
            if(str[str.size()-2] == c)
                flag = 1;
        }

        for(int i = 0; flag != 1  &&  i < str.size(); i++)
        {
            if(str[i] != c  &&  str[i] != f)
            {
                flag = 1;
                break;
            }
            if(str[i] == c)
            {
                if(i+1 < str.size()  &&  str[i+1] == c)
                {
                    flag = 1;
                    break;
                }
                if(i+2 < str.size()  &&  str[i+2] == c)
                {
                    flag = 1;
                    break;
                }
                flag = 2;
                cnt++;
            }
        }
        if(flag == 1 && str.size() == 1)
        {
            if(str[0] == f)
                ans = 1;
            else
                ans = -1;
        }
        else if(flag == 1 || str.size() == 0)
        {
            ans = -1;
        }
        else if(flag == 0)
        {
            ans = (str.size() + 1) / 2;
        }
        else
        {
            ans = cnt;
        }
        printf("Case #%d: %d\n", tt, ans);

    }
    return 0;
}

 

HDU 5455 Fang Fang

标签:

原文地址:http://www.cnblogs.com/wmxl/p/4829299.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!