码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2828 Buy Tickets【线段树单点更新】【逆序输入】

时间:2015-09-22 21:48:45      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 16273   Accepted: 8098

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

技术分享

题意:排队买票,给一个整数n接下来n行每行两个数a,b表示b这个数字插在第a个数字后边

题解:此题建树的时候需要逆序输入数据,这样将后续的人员在对应位置向后插入即可

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 200005
using namespace std;
int sum[MAX<<2];
int ans[MAX];
void pushup(int o)
{
	sum[o]=sum[o<<1]+sum[o<<1|1];
}
void gettree(int o,int l,int r)
{
	if(l==r)
	{
		sum[o]=1;//起始时刻,让所有的位置都站上人 
		return ;
	}
	int mid=(l+r)>>1;
	gettree(o<<1,l,mid);
	gettree(o<<1|1,mid+1,r);
	pushup(o);//建成的树最底端每个位置都是第一个越往根部,人的编号越大,根处 
}           //编号为n 
void update(int o,int l,int r,int pos,int v)
{
	if(l==r)
	{
		sum[o]=0;//当这个位置 
		ans[r]=v;	   
		return ;
	}
	int mid=(l+r)>>1;
	if(pos<=sum[o<<1])
	    update(o<<1,l,mid,pos,v);//搜索左子树 
	else 
	    update(o<<1|1,mid+1,r,pos-sum[o<<1],v);//搜索右子树因为右子树左端的值是 
	pushup(o);                               //左子树右端值+1所以查找右子树位置时 
}                                           //查找到pos-左子树长度就ok 
int main()
{
	int n,m,j,i;
	int a[MAX],b[MAX];
	while(scanf("%d",&n)!=EOF)
	{
		gettree(1,1,n);
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i],&b[i]);
		for(i=n;i>0;i--)  //逆序将数字放入 
		    update(1,1,n,a[i]+1,b[i]);//+1是因为题目数据是从0开始的 我们输数据的时候 
		for(i=1;i<=n;i++)		     //是从第一位而不是第0位输的  所以要+1,让位置对应 
			printf("%d ",ans[i]);
		printf("\n");
	}
	return 0;
}

  

poj 2828 Buy Tickets【线段树单点更新】【逆序输入】

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4830534.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!