码迷,mamicode.com
首页 > 其他好文 > 详细

(模板题)Number Sequence -- Hdu -- 1711

时间:2015-09-23 21:03:46      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

 

http://acm.hdu.edu.cn/showproblem.php?pid=1711

 

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16080    Accepted Submission(s): 7100


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 

 

Source

 

Next里面存的是前缀和后缀的最大相似度

Next[i] 代表的是前 i 个数的最大匹配

 

技术分享
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define N 1000007

int M[N], S[N], Next[N];

void FindNext(int Slen)
{
    int i=0, j=-1;
    Next[0] = -1;

    while(i<Slen)
    {
        if(j==-1 || S[i]==S[j])
            Next[++i] = ++j;
        else
            j = Next[j];
    }
}



int KMP(int Mlen, int Slen)
{
    int i=0, j=0;

    FindNext(Slen);

    while(i<Mlen)
    {
        while(j==-1 || (M[i]==S[j] && i<Mlen && j<Slen))
            i++, j++;
        if(j==Slen)
            return i-Slen+1;

        j = Next[j];
    }
    return -1;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, m, i;

        scanf("%d%d", &n, &m);

        for(i=0; i<n; i++)
            scanf("%d", &M[i]);
        for(i=0; i<m; i++)
            scanf("%d", &S[i]);

        printf("%d\n", KMP(n, m));
    }
    return 0;
}
View Code

 

(模板题)Number Sequence -- Hdu -- 1711

标签:

原文地址:http://www.cnblogs.com/YY56/p/4833430.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!