码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1915: Knight Moves

时间:2014-07-18 23:12:55      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:poj

Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 21362
Accepted: 9926

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
bubuko.com,布布扣

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

BFS。和2243差不多。。要你输出从起点到终点最短的步数



#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
#include<vector>

using namespace std;

const int N = 305;
int n;
char color[N][N];
int vist[N][N];

int dx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int dy[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int xx;
int yy;
struct node
{
    int x;
    int y;
    int num;
};
queue<node>q;
node a, b;

void bfs()
{
    vist[a.x][a.y]=1;
    while( !q.empty() )
    {
        node temp = q.front();
        if( temp.x==b.x && temp.y==b.y )
        {
            printf("%d\n", temp.num);
            return ;
        }
        q.pop();
        for(int i=0; i<8; i++)
        {
            xx = temp.x + dx[i];
            yy = temp.y + dy[i];
            if( xx<0 || xx>=n || yy<0 || yy>=n || vist[xx][yy])
                continue;
            node next;
            next.x = xx;
            next.y = yy;
            next.num=temp.num+1;
            vist[xx][yy]=1;
            q.push( next );
        }
    }
}

int main()
{
    int i,j;
    int cas;
    scanf("%d", &cas);
    while( cas-- )
    {
        scanf("%d", &n);
        scanf("%d%d%d%d", &a.x, &a.y, &b.x, &b.y);
        while( !q.empty() ) q.pop();
        memset( vist, 0, sizeof(vist) );
        node first;
        first.x = a.x;
        first.y = a.y;
        first.num=0;
        q.push( first );
        bfs();
    }

    return 0;
}







POJ 1915: Knight Moves,布布扣,bubuko.com

POJ 1915: Knight Moves

标签:poj

原文地址:http://blog.csdn.net/u013487051/article/details/37886167

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!