码迷,mamicode.com
首页 > 其他好文 > 详细

Tempter of the Bone

时间:2014-07-18 22:25:05      阅读:246      评论:0      收藏:0      [点我收藏+]

标签:奇偶剪枝   dfs   

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: ‘X‘: a block of wall, which the doggie cannot enter; ‘S‘: the start point of the doggie; ‘D‘: the Door; or ‘.‘: an empty block. The input is terminated with three 0‘s. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
char a[10][10];
bool f[10][10], flag;
int n, m, t, xx, yy;
int vir[] = {0, 1, 0, -1, 0};
int dfs(int x, int y, int temp)
{
    if (flag)return 0;
    if (x == xx && y == yy && temp == t) {
        flag = 1;
        return 1;
    }
    if (temp > t)return 0;
    f[x][y] = 1;
    int mp = abs(x - xx) + abs(y - yy);
    mp = t - mp - temp;
    if (mp & 1)return 0;
    for (int i = 0; i < 4; i++) {
        int ax = x + vir[i];
        int ay = y + vir[i + 1];
        if (ax >= 1 && ax <= n && ay >= 1 && ay <= m && a[ax][ay] != 'X' && f[ax][ay] != 1) {

           // f[ax][ay] = 1;
            dfs(ax, ay, temp + 1);
            //f[ax][ay] = 0;
        }
    }
    f[x][y] = 0;
    return 0;
}
int main()
{
    int x, y;
    while (scanf("%d %d %d", &n, &m, &t)) {
        if (n == m && m == t && t == 0)break;
        flag = 0;
        memset(f, 0, sizeof(f));
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= m; j++) {
                cin >> a[i][j];
                if (a[i][j] == 'S') {
                    x = i;
                    y = j;
                    a[i][j] = '.';
                }
                if (a[i][j] == 'D') {
                    xx = i;
                    yy = j;
                    a[i][j] = '.';
                }
            }
        dfs(x, y, 0);
        if (flag)
            printf("YES\n"); // << endl;
        else  printf("NO\n");

    }
    return 0;
}


Tempter of the Bone,布布扣,bubuko.com

Tempter of the Bone

标签:奇偶剪枝   dfs   

原文地址:http://blog.csdn.net/zhangweiacm/article/details/37885143

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!