码迷,mamicode.com
首页 > 其他好文 > 详细

C_Dp

时间:2014-07-18 22:28:24      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   2014   io   

<span style="color:#000099;">/*
C - 简单dp 例题
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output
4
2
0
By Grant Yuan
2014.7.16
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
char a[1000];
char b[1000];
int dp[1000][1000];
int max(int aa,int bb)
{
    return aa>=bb?aa:bb;
}
int main()
{   int l1,l2;
    while(~scanf("%s%s",a,b)){
        l1=strlen(a);
        l2=strlen(b);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<l1;i++)
          for(int j=0;j<l2;j++)
            {
                if(a[i]==b[j])
                  dp[i+1][j+1]=dp[i][j]+1;
                else
                  dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
            }
        cout<<dp[l1][l2]<<endl;
      }
      return 0;
}
</span>

C_Dp,布布扣,bubuko.com

C_Dp

标签:des   style   color   os   2014   io   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/37879679

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!