码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ-3822

时间:2015-09-30 20:52:17      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:

 

Domination

Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What‘s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That‘s interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

 

技术分享
/**
    题意:如题
    做法:dp dp[i][j][k]   表示下第i枚棋  在j,k的位置 
**/
#include <iostream>
#include <algorithm>
#include <cmath>
#include <string.h>
#include <stdio.h>
using namespace std;
#define maxn 60
double dp[maxn * maxn][maxn][maxn];
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n, m;
        memset(dp, 0, sizeof(dp));
        scanf("%d %d", &n, &m);
        dp[0][0][0] = 1.0;
        for(int i = 0; i < n * m; i++)
        {
            for(int j = 0; j <= n; j++)
            {
                for(int k = 0; k <= m; k++)
                {
                    dp[i + 1][j + 1][k + 1] += dp[i][j][k] * (n - j) * (m - k) / (n * m - i);
                    dp[i + 1][j][k + 1] += dp[i][j][k] * j * (m - k) / (n * m - i);
                    dp[i + 1][j + 1][k] += dp[i][j][k] * (n - j) * k / (n * m - i);
                    dp[i + 1][j][k] += dp[i][j][k] * (k * j - i) / (n * m - i);
                }
            }
        }
        double ans = 0;
        for(int i = 1; i <= n * m; i++)
        {
            ans += i * (dp[i][n][m] - dp[i - 1][n][m]);
        }
        printf("%.10f\n", ans);
    }
    return 0;
}
View Code

 

ZOJ-3822

标签:

原文地址:http://www.cnblogs.com/chenyang920/p/4850144.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!