标签:des style blog color strong os
Y2K Accounting Bug
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 10050 |
|
Accepted: 5007 |
Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.
Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two positive integers s and d.
Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000
Sample Output
116
28
300612
Deficit
题意:只要是连续5个月,则该公司在这5个月期间的盈和亏总和小于零(亏损),求全年的盈亏。(连续5个月的盈和亏总和小于零(亏损))
思路:要计算出连续5个月至少有哪几个月亏损。
#include<stdio.h>
int main ()
{
int n,m;
int i,sum;
while(~scanf("%d%d",&n,&m))
{
sum=0;
for(i=1;i<=5;i++)
if(n*(5-i)-m*i<0)
break;
if(i==4) // 特殊考虑
sum=3*n-9*m;
else
sum=n*(12-2*i)-m*2*i;
if(i==5||sum<0)
printf("Deficit\n");
else printf("%d\n",sum);
}
return 0;
}
poj 2586 Y2K Accounting Bug,布布扣,bubuko.com
poj 2586 Y2K Accounting Bug
标签:des style blog color strong os
原文地址:http://blog.csdn.net/fyxz1314/article/details/37901053