码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1518 Square(深搜dfs)

时间:2014-07-17 10:52:02      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:hdu   dfs   

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518


----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣bubuko.com,布布扣http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 
Sample Input
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 
Sample Output
yes no yes

题意:

问所给的短棒能否组成一个正方形。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int a[32], vis[32];
int flag, sum, tsum, n;

void dfs(int edge,int len,int pos)
{
    int i;
    if(edge == 4)
    {
        flag = 1;
        return ;
    }
    if(len == tsum)
    {
        dfs(edge+1,0,0);//从0开始重新搜索
        if(flag)
            return ;
    }
    for(i = pos; i < n; i++)
    {
        if(!vis[i] && len+a[i] <= tsum)
        {
            vis[i] = 1;
            dfs(edge,a[i]+len,i+1);
            if(flag)
                return;
            vis[i] = 0;
        }
    }
}

int main()
{
    int t, i;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            memset(vis,0,sizeof(vis));
            sum = 0, flag = 0;
            scanf("%d",&n);
            for(i = 0; i < n; i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
            }
            if(sum%4 != 0)
            {
                printf("no\n");
                continue;
            }
            tsum = sum/4;
            for(i = 0; i < n; i++)
            {
                if(a[i] > tsum)
                {
                    flag = 1;
                    break;
                }
            }
            if(flag == 1)
            {
                printf("no\n");
                continue;
            }
            dfs(0,0,0);
            if(flag)
                printf("yes\n");
            else
                printf("no\n");
        }
    }
    return 0;
}


hdu 1518 Square(深搜dfs),布布扣,bubuko.com

hdu 1518 Square(深搜dfs)

标签:hdu   dfs   

原文地址:http://blog.csdn.net/u012860063/article/details/37901013

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!