码迷,mamicode.com
首页 > 其他好文 > 详细

【UVa 712】S-Trees

时间:2015-10-04 11:00:16      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享
 

A Strange Tree (S-tree) over the variable set 技术分享 is a binary tree representing a Boolean function 技术分享. Each path of the S-tree begins at the root node and consists of n+1 nodes. Each of the S-tree‘s nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn. All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables技术分享 is called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0‘s and 1‘s on terminal nodes are sufficient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables 技术分享, then it is quite simple to find out what 技术分享 is: start with the root. Now repeat the following: if the node you are at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.

 

技术分享

 

Figure 1: S-trees for the function 技术分享

On the picture, two S-trees representing the same Boolean function, 技术分享, are shown. For the left tree, the variable ordering is x1x2x3, and for the right tree it is x3x1x2.

The values of the variables 技术分享, are given as a Variable Values Assignment (VVA) 

 

技术分享

 

with 技术分享. For instance, ( x1 = 1, x2 = 1 x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value 技术分享. The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes 技术分享 as described above.

 

Input 

The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer n技术分享, the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1xi2 ... xin. (There will be exactly n different space-separated strings). So, for n = 3 and the variable ordering x3x1x2, this line would look as follows:

x3 x1 x2

In the next line the distribution of 0‘s and 1‘s over the terminal nodes is given. There will be exactly 2n characters (each of which can be 0 or 1), followed by the new-line character. The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be 0 or 1), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

110

corresponds to the VVA ( x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

 

Output 

For each S-tree, output the line `` S-Tree #j:", where j is the number of the S-tree. Then print a line that contains the value of 技术分享 for each of the given m VVAs, where f is the function defined by the S-tree.

Output a blank line after each test case.

 

Sample Input 

 

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0

 

Sample Output 

S-Tree #1:
0011

S-Tree #2:
0011

 


Miguel A. Revilla
2000-02-09
 
题目看了半天。。。
搞懂了,其实很简单,用叶子节点构建一棵完全二叉树,然后按查询查找即可。
#include<cstdio>
#include<cstring>

using namespace std;

int n, m, kase;
char s[1 << 8], cmd[1 << 8];

int main()
{
    kase = 0;
    while (scanf("%d", &n) == 1 && n)
    {
        for (int i = 0; i < n; ++i) scanf("%*s");
        scanf("%s", s);
        scanf("%d", &m);
        printf("S-Tree #%d:\n", ++kase);
        for (int i = 0; i < m; ++i)
        {
            scanf("%s", cmd);
            int u = 0;
            for (int j = 0; j < n; ++j)
                if (cmd[j] == 1) u = 2 * u + 1;
                else u *= 2;
            printf("%c", s[u]);
        }
        printf("\n\n");
    }
    return 0;
}

 

【UVa 712】S-Trees

标签:

原文地址:http://www.cnblogs.com/albert7xie/p/4854214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!